No credits from donation

So I made a donation yesterday but I didn’t receive the credits yet. I was redirected to the login page but when I log in my in-game account it went into an error saying “forbidden”.
I reloaded the page, login again then still no credits.

theres no way that can happen, can you give more clarification and proof
(and screenshots if applicable, will give large amount of proof, but not honesty yet.)
and try being honest

I censored some informations because it may be sensitive

  • this is the first donation.
    redirected to the page but I don’t recall what happened. I think I refreshed the page after logging in.

-I tried donating again out of curiosity because I waited like 1hr+.
-this time it redirected me to the login page of trading system (same as the 1st one)
and it says “forbidden”. I refreshed the page and logged in but still no credits.


both of the transaction was deducted to my card
-This is the application from my phone

-screenshot of the trading system page as of 12:50am GMT+8.

If you’re still questioning my honesty. I have the receipt in email which I can forward.

You need to contact popstarfreas to receive your credits

i was going to say that .[].