Placed blocks are sometimes client-sided only and do not exist on other player's screens/ isn't taken into account by the server

PC/Mobile
Afaik all platforms

Dimensions or Services it affects
Survival

Your in-game account name
Basilica

How often it happens
Depends on the environment; it can be more or less likely depending on what is happening. I’ve observed it happens more commonly when you are picking up items while placing blocks, when the server is lagging, and when you place a lot at once

Any screenshots or videos showing the bug

4 Likes

Adding on a pathetic example compared to the video presented here, here was a house that @Water_Bottle build back in August this year in Survival. The missing walls in the corner around the Heart Lantern weren’t forgotten about, they just wouldn’t be placed on the server side.


Water tried rejoining multiple times to place them down. It didn’t work. They tried adding me to the house and I tried placing the walls. Similarly to the video shown above, they appeared on my client, but then disappeared as soon as I left and rejoined Survival. I got fed up with it and just took the screenshot with the broken walls to show off the otherwise nice house.

7 Likes

I can’t see this problem when I do it myself (PC) using the architect gizmo pack for faster placing. Is there something in particular you are doing or have when placing that causes this to happen?

Alternatively, if this occurs often enough, you can repeat it on the testing version so I can capture what happens.

7 Likes

I think it mainly depends on your internet connection. Something similar happened with walls back when TrueSSC was first implemented, and it was because multiple walls were being automatically placed by the game at a time, resulting in a lot of holes appearing in peoples’ builds.

I hypothesize that lag is an important factor in this. Perhaps because of even just minor lag, the placement of some blocks may be delayed, and as a result the game could end up telling the server that multiple blocks have been placed at the exact same time, causing TrueSSC to reject it, and resulting in the client-side block glitch. That’s just a theory though, but it also seems very likely to me.

6 Likes

Did you happen to type /void because a guy told you to do it for free stuff?

4 Likes

there is a stream of chat messages throughout the video, and no instance of activating /void

also, the deleted blocks were in random placement order? the blocks would disappear in order after the void timestamp

4 Likes