I can't login to server

It says that you are using a different version then this server even though i terraria 1.3.1 but in the bottom it says 3.1.1 does it matter to the server. does it just have to be 1.3.1

If the server is running 1.3.1 and you have 1.3.1.1, then you’re running an entirely different version of the game. you MUST have the exact same version of the game as the server in order to join.

im new so i dont know how to get in the server